PHP 5.6 a 7.0 jsou verzemi, které podle statistik pohání přes polovinu (konkrétně nějakých 57 %) webových stránek postavených na WordPressu. Tedy to jsou čísla před prosincem letošního roku (2018). Právě od tohoto měsíce totiž tyto verze přestávají oficiálně dostávat bezpečnostní záplaty. Podporované už nejsou mnohem déle.

Co to znamená v praxi?

Především u PHP verze 5.6 jsme už daleko za životností a přichází tak fáze, kdy zranitelnost objevená v těchto verzích může být zneužita.

 

Tabulka podpory PHP verzí

Tabulka podpory PHP verzí (zdroj: PHP.net)

Jak můžete vidět, tak koncem roku vyprší prodloužená lhůta bezpečnostní podpory pro PHP 5.6. Jedná se o tzv. End of Life (EOL), tedy konec životnosti a pravděpodobně tak nebudou nejen vydávány vylepšení, ale především bezpečnostní záplaty.

PHP 5.6 je sice stále velmi používanou verzí, ale velmi starou. Verze 7.0 a novější přinesly především výrazné zvýšení výkonu. U WordPressu je to pro mnohé weby citelné zlepšení, kvůli kterému se vyplatí upragradovat. Kvalitní poskytovatelé webhostingu by měli nabízet možnost si verzi zvolit či změnit prostřednictvím podpory. Další možností je přesun webu k jinému poskytovateli.

Co je vlastně PHP?

PHP je skriptovací programovací jazyk, který se využívá zejména pro dynamické webové stránky a aplikace. Podle statistik W3Techs pohání 78,9 % webů.

Důležité je, že je základem právě WordPressu, takže je nutné mít jeho podporu na webhostingu a dostatečné parametry. Šablony a pluginy dnes často podporují pouze některé verze PHP, např. nemusí být ještě aktualizované pro nejnovější, takže je potřeba hlídat jejich kompatibilitu.